Sign in to follow this  
Followers 0
LEGENDOFNHL94

controller config help

11 posts in this topic

Hi all,

i cant get my joypad set up. it works fine in windows control panel. But when i start GENS i get this error

erreur joystick

IDirectInputDevice: :SetProperty() (Y-axis) FAILED

WTF?!?!

ive deleted my config file, same thing. When i go to set up joypad, it just cycled through all the options (UP DOWN ETC....) automatically....

im using win7 64 bit

Share this post


Link to post
Share on other sites
Hi all,

i cant get my joypad set up. it works fine in windows control panel. But when i start GENS i get this error

erreur joystick

IDirectInputDevice: :SetProperty() (Y-axis) FAILED

WTF?!?!

ive deleted my config file, same thing. When i go to set up joypad, it just cycled through all the options (UP DOWN ETC....) automatically....

im using win7 64 bit

might need to run it in compatibility mode or something. (i think there is some way to emulate winXP in win7?)

Share this post


Link to post
Share on other sites

Same issue, Windows 10, can't get this error to clear, nor my diags to work on any joystick, and I've tried about a half dozen different types. What did you do to fix this?

Share this post


Link to post
Share on other sites

Same issue, Windows 10, can't get this error to clear, nor my diags to work on any joystick, and I've tried about a half dozen different types. What did you do to fix this?

What kind of joystick are you using?

Share this post


Link to post
Share on other sites

So, I don't have a "fresh" memory of what issues I was having, but I can relate my story here and hopefully it might help some solve their issues.

Whenever I use the genesis joystick adapter to play with an original genesis joystick on my CPU that runs windows 10, I needed to use Gens Plus emulator, not Gens to get them to work. Very similar program and you can play online with it vs someone using Gens the same, but some of the full screen, save features, etc have different key options, and when I use Gens Plus, I can't exit out of full screen mode without crashing for some reason. I just googled/downloaded Gens Plus from one of the many emulator sites.

This is primarily why I don't use the Gens joysticks, because I don't like Gens Plus as much. I'd rather have an easier time navigating with a slightly less optimum joystick.

IN ADDITION, I found ANY joystick (I've tried several different ones over the past few years) that when configured and used in GENS, if the DIAGONAL's didn't work as Tony mentioned, then if I used GENS PLUS, the diagonals worked. Joysticks that worked in GENS, didn't seem to always work in GENS Plus! Weird?!!?

The fix I found to use any joystick inside of GENS, and not have to download/use Gens Plus, is a program called MotionJoy, but it is very controversial and can often lead to viruses if you don't use it properly. Someone coded an additional program that enables you to run MotionJoy and configure your joysticks without the virus complication. IF I could find this online via google, then I'm sure those desperate enough can too. I didn't bookmark anything and I'm at work now anyhow.

But long story, it requires a lot of work to get this. It's how I would use my PS3 D pad instead of analog sticks. However, since I started sharing my big screen computer with the family, I didn't want all these programs running in the background and just switched to this simply but easy joystick.

SNES Buffalo Classic.

Configuration is beyond easy, D pad works, buttons work, and it cost like $10. Not 1000% best "joystick", but 1000% easiest to buy/setup/play and lasts a decent while. For those tired of being tired and want an easy plug and play fix, this is my recommendation.

Share this post


Link to post
Share on other sites

SNES Buffalo Classic.

Configuration is beyond easy, D pad works, buttons work, and it cost like $10. Not 1000% best "joystick", but 1000% easiest to buy/setup/play and lasts a decent while. For those tired of being tired and want an easy plug and play fix, this is my recommendation.

I use this, too. So does Zep, so does Atomic.

I play a lot and burn through one every 2-3 months, but at $11 from Amazon, not a big deal. Yup, it just works.

Share this post


Link to post
Share on other sites

From: http://www.gens.me/faq.html

Q : I got the following message : "Error with Query Interface", how fix it ?[/size]

A : You just have to reinstall directX 7.0 (or above).

Q : I can't set my joypad because keys are automatically pressed (quickly), what's the problem ?

A : Some people have experienced problems getting Gens to use their Joypad because when they press a button on the Joypad Gens reads multiple inputs and sets all the controls to one button! To fix this you should reinstall your Joypad drivers and then reinstall DirectX 7.0, don't forget to recalibrate your Joypad before running Gens though. If this doesn't fix the problem it is probably your Joypad drivers that are at fault, check for newer versions, unfortunately there is nothing else I can do about this problem and you'll have to use the Keyboard.

Q : I can't get diagonals using my joypad, or diagonals have stopped working how do I fix it?

A : Several people have reported this problem and it seems to be a Gens.cfg problem. Quit Gens, find and delete your Gens.cfg file. Now restart Gens and set your joypads up again, hopefully you should now be able to get diagonals.

Edited by jer_33

Share this post


Link to post
Share on other sites

Confirmed functionality with Gens plus. Will keep the controllers. I still get the alert on start about the inputs, but the diagonals work, and when tested with Jer_33, the connection seemed stable while he hosted.

Next challenge, have been unable to host games on my end, even with hamachi, not sure why.

Share this post


Link to post
Share on other sites

Usually if you struggle to host on your end, but not when connecting, it's 99% your firewall settings.

Try for one game disabling your firewall. If that works, then you know you need to go into your firewall and mess with it.

It needs to allow Gens Plus & Gens access, since you are using both.

Share this post


Link to post
Share on other sites

Usually if you struggle to host on your end, but not when connecting, it's 99% your firewall settings.

Try for one game disabling your firewall. If that works, then you know you need to go into your firewall and mess with it.

It needs to allow Gens Plus & Gens access, since you are using both

I run a DD-WRT flashed router with no game mode settings. Firewall is turned off on the software level. If port forwarding of some kind is required I would need to know exactly what port or ports need to be opened.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0