Sign in to follow this  
hokkeefan

need help with basic logitech f310 controller

Recommended Posts

ive tried everything and it hardly moves and just wont work right grrrrrrrrrrrrrrrrrr,i still have to wait a week for sega adapter

Share this post


Link to post
Share on other sites

Good luck with that. Ive had zero luck with anything but cheap controllers. Similar issues like diagnols dont work etc

Share this post


Link to post
Share on other sites

yeah fkin no diagonals,grrr ,oh well i will use crap xbox controller for this week

Share this post


Link to post
Share on other sites

my only guess is try toggling the "analog" button if there is one.

and reboot your computer? :P

Share this post


Link to post
Share on other sites

I finally figured out how to config my Logitech dual action controller. I needed to go into the controller properties and swap dpad with analog stick. Now my dpad works fine including angles which didnt work before

Share this post


Link to post
Share on other sites

I have been using logitech gamepads for a while, but they all have some unique problem. How good are the Xbox360 gamepads for emulation gaming??

Share this post


Link to post
Share on other sites

Haha back to 1992! I just picked up retro usb converter and dug up my old sega controller! Highly recommended fellas they def don't make them like they used to

post-1168-0-83857000-1362698001_thumb.jp

Share this post


Link to post
Share on other sites

I finally figured out how to config my Logitech dual action controller. I needed to go into the controller properties and swap dpad with analog stick. Now my dpad works fine including angles which didnt work before

Two cheapie controllers I had broke in 2 days! So I bought the Logitech 310. Diagnols not working. :(

Where is this "controller properties"?

Is it built in to Windows? (I use Win7.)

Or is it part of some Logitech Utility software I have to install? (I prefer just installing drivers; hate extra bloatware. But If I need it, so be it.)

Edited by aqualizard

Share this post


Link to post
Share on other sites

Thanks for the link. I installed the latest version of Logitech's crap software. (The old version of their crap software could not be found.)

The device cannot be found in the Control Panel, and when I run the crap Logitech software directly, it says not gaming device can be detected. (Which is strange, because the drivers installed correctly, and the I can use the controller with Gens, it just can't move diagonally.)

This is frustrating, but not surprising. But I don't have time to troubleshoot this at the moment. EFFING COMPUTERS!!!!

Edited by aqualizard

Share this post


Link to post
Share on other sites

I think there is something about the compatibility between the Genesis emulators (and NES ones, too) that the SNES emulators do not suffer from. I can't get ANY of my four vastly different controllers to play NES nor Genesis ROMs without that drifting issue that makes them unplayable. I do believe there are programs and drivers that can address this. I recall using a separate program to calibrate and fix that stuff, once, long ago, on an old computer. I think the answer is out there. I think it's fixable. if you figure it out, I'm excited to give the Genesis/Sega CD versions another go. I know Kega is not a preferred emulator (controller delays or something), but I think it has more options for tweaking this stuff. good luck. I firmly believe that any controller can be used once you convince the crappy emulator of your choice to recognize. until then, switch to Snes9x.

Share this post


Link to post
Share on other sites

Just wanted to update this for people that are having this issue.  I did fix my issue, and had my controller working fine.  But I switched controllers because I didn't like the feel... Now I don't remember what the heck I did!  :wacko:

Anyway, there is a solution.  And it is somewhere on the forum.  If you find it, please put a link to it in this thread to help others.  :) (I will search myself as time allows...)

Edited by aqualizard

Share this post


Link to post
Share on other sites

Update:
I think this switch on the bottom might be the key... someone with a F310 use this link to try it out:

http://support.logitech.com/en_in/article/21696?product=a0qi00000069ueWAAQ

Below is a paste of the site, in case it goes missing sometime in the future....

On 4/16/2016 at 2:29 PM, aqualizard said:

USING THE INPUT MODE SWITCH ON THE GAMEPAD F310 TO SELECT DIRECTINPUT OR XINPUT
Updated:  08/31/2014 08:00 PM
The Wireless Gamepad F310 supports two different input modes:

  1. XInput (X)
  2. DirectInput (D)

These modes are selected using the switch located on the bottom of the F310, as shown below.
 

 

f310-trdfront.jpg

XInput (X)


XInput is the preinstalled, modern gamepad standard on Windows 7 and Vista. It can also be installed on Windows XP (SP1 or greater).


Use XInput to play games in Windows whenever possible. This input mode is intended to make the gamepad work natively with modern games.


If you're playing a new game with the F310 gamepad, we suggest you set the Input Mode switch to "X". If you want to customize the input functionality, try using DirectInput mode instead.

DirectInput (D)

DirectInput mode works with Windows drivers to enable basic input functionality. This input mode also lets you use the Logitech Gaming Software to customize the inputs for games that don't normally allow you to do so, or don't have gamepad support at all.

You can use the Logitech Gaming Software with DirectInput mode to assign a specific key or key combination to any of the buttons or thumbsticks on the gamepad. You can also assign each thumbstick to work like a joystick or mouse.

NOTE: Logitech doesn't provide configuration software for non-Windows systems, but many games allow you to configure inputs in-game. DirectInput mode lets the gamepad communicate with the drivers on many such systems.

 

 
Edited by aqualizard
  • Thanks 1

Share this post


Link to post
Share on other sites
On 2/17/2013 at 5:59 PM, smozoma said:

my only guess is try toggling the "analog" button if there is one.

and reboot your computer? :P

This worked for me just, Hit the mode button remap your dpad and it will work. Also if you turn off mode it will be on your left thumb stick.

Share this post


Link to post
Share on other sites

Took me a few tries, but got it to work with help from a few guys.

  1. Plug in the F310 gamepad
  2. Open Gens Emulator
  3. Press the Mode button on the gamepad so that the green light is on
  4. Click Option in Gens Emulator
  5. Select Joypads...
  6. Map the buttons
  7. Click OK

Test it out. Should be ready to deke.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this