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WARNING - This thread is extremely graphics-heavy - if you are viewing
on a mobile device or slow internet connection, you will experience
delays, etc.

This is the thread for that kind of stuff. 

As the title says, I'll be posting the teams graphics: logos, jerseys, and so on here as they appear.

I'll also be posting links the game ROMs as I modify them. They can be used to testing, simming and just playing around with.

I'll be posting some things to help with other parts of the game too, such as the file below.

Lastly, in the future I'll be posting some things like tutorials and tips for people interested in modifying their own NHL 94 emulator games.
I put a lot of time into learning how to do it, and when I started I was doing a lot of things the hard way. Over time I found better resources
and techniques, which made things a lot faster and easier. A lot of these things were invented by other people, so I'll be giving credit to
those people as it comes up.
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The first item is this:
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https://drive.google.com/file/d/0B354l2YN_7EneHNzdUQ3N3JVcFE/view?usp=sharing

This is a .psd file for testing out uniform designs for the in-game player sprites.

Each colour is a separate layer. To change a colour, find the layer with the colour you want to change, open the effects and change the
Colour Overlay settings to the colour you want.

The game has a limited pallet for the sprites, so using "Only Web Colours" when choosing a colour will give you the most accurate
results.

Also, there are some colours that are not on layers. Those are the colours that we will not be changing in the game, such as the ice,
sticks and skate colours.

Ken Meredith
The Community



THETFORD MINERS SEASON ONE

 

Thetford Miners
Too sweet! 

Jerseys:

Spoiler

Last edited: Sep 22, 2017
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VANCOUVER VOODOO SEASON ONE
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LOGO

Spoiler

HOME JERSEYS

Spoiler

AWAY JERSEYS

Spoiler

PLAYER JERSEYS

Spoiler
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Mod graphics: City names for the in-game menu screen.
      

(You really get an idea of how small the graphics really are, don't you?)

Ken Meredith
The Community



MARITIME ARMADA Season 1
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WINDSOR CASSOWARY Season One
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IDAHO MASHERS Season 1

Spoiler: Logo
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The rest might come in later as time goes on, or maybe not, who knows...
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CONEY ISLAND CONES Season 1

Ken Meredith
The Community



MODIFYING NHL '94 - Part One: Essential Resources

If you're setting out to make your own version of NHL '94, there are some things you will need to do:

First, I recommend signing up at nhl94.com A lot of the software I'm using I got there. You can probably find some of it through Google,
but nhl94.com has most everything under one virtual roof.

Here are the bits of software you'll need, either from there or wherever:
1. A graphics application, like GIMP or Photoshop
2. NHL Old Skool Editor (NOSE) 

https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-58182
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-58182
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-58182
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-58215
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-58215
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-58215
http://forum.nhl94.com/
http://forum.nhl94.com/index.php?/topic/14217-nose-12b-download/
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3. EA Rom Editor (EARE)
4. Tile Molester (TM is a Java program, so you may need to set that up on your system as well)
5. A SEGA Genesis Emulator for whatever system you're using. I recommend Kega Fusion, which is available for many platforms.

You'll also need a ROM to edit. I recommend using the BLITZ SEASON 3 from THIS page, or our own BESL Season 8 ROM

I will be using various files that I have made, which I will upload and share as they are needed for my tutorials.

Next: I actually start doing stuff with all this. 
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MODIFYING NHL '94 - Part Two: Essential graphics

So, now you've got all your software set up and it's time to get modding, right?

Almost.

If you don't have anything to put into the game, it's going to be a short night.

So let's start with that.

You'll need your team graphics. Luckily for me, I have this thread, so almost everything I need is here.

First, I'm going to make the team centre ice and select screen logos.

As an example, I'm going to use the BIHL's first team, the Thetford Miners.

Here's their logo:

 

I'm going to save it onto my computer, then open it up in Photoshop.

http://forum.nhl94.com/index.php?/topic/10443-eare-ea-rom-editor-for-nhl94/
http://www.romhacking.net/utilities/109/
http://segaretro.org/Kega_Fusion
http://www.blitz94.com/downloads.asp
https://drive.google.com/open?id=0B354l2YN_7EnSDI2Y0JGWXFYNEk
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-58632
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-58632
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-58632


Next I'm going to make it a limited pallet image to make it more compatible with the game.
Click Image>Mode>Indexed Color, then change the settings to match these:

 
Click OK and you'll get an image with a pallet limited to eight colours.

Next click Image>Canvas Size

 
Next, change the lower value to match the higher value. In this case, the Width is smaller than the Height. To make it a square, change
the 375 to 400. To properly resize the image for the ice logo, it should be a square.



Next, we're going to resize the image to the correct size and deformation.
Click Image>Image Size and change the settings to this:

 
It's important to make sure Constrain Proportions is off, since we're changing the logo dimensions. This is because the game is not
looking at the ice from directly above, but at an angle, so the logo should be slightly "slanted."

It should look something like this:

Save this image as a .png file and you're finished your Miners centre ice logo!

While we're here, let's make the Miners Select Screen logo, too!

Press Ctrl-Alt-Z to revert your logo back to full size.

There are two ways to make a select screen logo. One way is to use Image>Image Size and change the size settings to 48x48 pixels.
That will give you a select screen logo of the entire logo.

The way I like to do it is to select only part of the logo and make it a close-up. That's the way I'll show you now.

Select the Crop tool.

Next change the settings in the top bar to this:
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 cinnamon

Then select the part of the logo you want to make the select screen graphic:

 
Click the check mark or double-click the image to select.

It should look something like this:

 

Save this image as a .png file and you've finished your first select screen logo!

Do this with the rest of your team logos and you've completed the first step!

Next - Team city banners
Last edited: Oct 2, 2017
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MODIFYING NHL '94 - Part Three: City Name Banners

In the game pause menu screen there are city name banners like these:

 
We're going to make the basic graphics for these banners. 

It's important to note that we will not be changing the colours in Photoshop. We'll do that later using a different application, where it is a
little easier for me.

First, you need to download these two .psd files:
https://drive.google.com/open?id=0B354l2YN_7EnOGdCRVRBM3JfSmM
and
https://drive.google.com/open?id=0B354l2YN_7EnRkl2bXI2dHYwaVU

Then open them in Photoshop. 

Before you do make any new names, browse through the layers in the blank name bar file. I have already made banners for a few
different places.

This is the blank name bar:

https://drive.google.com/open?id=0B354l2YN_7EnOGdCRVRBM3JfSmM
https://drive.google.com/open?id=0B354l2YN_7EnRkl2bXI2dHYwaVU


and these are the letters:

To make it easier, I've put each of the letters we'll be using on a separate layer. To select a letter hold Ctrl and click on the little box to the
left of the layer name called the Layer Thumbnail:

 
That will select just the single letter.



 
Click the layer name to make sure it's selected, and press Ctrl-C to copy. Then go to the blank name bar and click Ctrl-V to paste it onto
the bar. Use the Move tool to slide the letter to the left or right.

 
Copy and paste the remaining letters, and use the Move Tool to arrange them into the name.

 
You'll notice that you have a lot of layers. What I do to simplify things is merge the layers together once I have the name done, but
without the base of the bar.

In the layer pallet, click the little eyeball next to Layer 0 to make it invisible.

Then LEFT-click on the blue layer and select Merge Visible to create a single layer with all the letters on it.

Then click the eyeball next to Layer 0 again to make it visible, then use the Move tool to centre the letters on the bar.
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Save this as a .png file and you're done the name banner for the Idaho Mashers!

Repeat the process for the rest of the city names you want to enter and you're done this part!

Next - using your NOSE and EARE

Ken Meredith
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SYRACUSE BLIZZARD Season One

Spoiler: Main Logo

The S is for Syracuse of course.

Spoiler: Secondary Logo

A beautiful font, with the same snowflakes from the S.

Spoiler: Uniforms

Ken Meredith
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MODIFYING NHL '94 - Part Four: Using your NOSE and EARE

Okay, if you don't already have them, scroll up and get NOSE and EARE., as well as a ROM to use. I'm going to use the Blitz94 Season
3 (ab v3) ROM I suggested above as well.

Let's start by opening up NOSE

First we're going to click File>Open and open the ROM

Your screen should look something like this:

https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-59364
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-59364
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-59364
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-59387
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-59387
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-59387


As you can see, each sub-window has a matching button on the top menu bar. That's important since it makes things easy to navigate.
I'm going to start with the Teams Window, so click the T button on the menu bar.

Next (and this is very important) click the Auto Manage Free Bytes button here:

 

What this does is it sets NOSE to manage the unused data portions, allowing you to change the length of certain data strings in the
game. Remember, this game comes from an era where every byte of data is carefully managed to fit on a cartridge that only holds a tiny
bit of memory compared to today. If you don't click this, you won't be able to change the number of characters in any name.

Next, Let's double-click on the top team (in this case Anaheim) to edit the information. This window should appear:

 
Let's edit the information. I'm going to change this to the BIHL's first team (alphabetically), The Coney Island Cones:



 
The Cones haven't chosen an arena yet, so I'm putting in the name of their BESL club as a placeholder. You'll also notice that the Free
Bytes number at the bottom has gone down. That's because I've used more characters in the information than in the base ROM.

Click OK. If you want to change another team's information, do it the same way. 

Next, let's enter some player information and attributes.

Click on the G Button the open the Goalies window.

Then double-click on the goalie you want to edit, in this case, I want to change Dominik Hasek into the Cones superstar 'keeper, Tyler
Argh'Mahda.
Before:



 
After:

 
Notice that there are some attributes that say Leave at Zero. Leave them at Zero. 

Also, Tyler has an apostrophe in his name, but since the game doesn't recognize them in player name strings, I have to erase it. Also,
the game is fussy about guys with three names and stuff like that, so you may have to change things to fit. 

Click OK

You'll notice that Tyler is on the goalie roster, but he's not on the top of the list. I want him to be the starting goalie, so he has to be on
the top.

To move him up, click on his name, then click the Move Up button:

 
and he should change positions:



 
Like so. Tyler is now your number one goalie.

Next, let's change some forward and defender attributes.

Click the P Button to access the Player Window.

Like the Goalie attributes, double-clicking on a player will let you edit him.

Let's change Steve Larmer into Coney Island's star sniper Jack Burton:
Before

 
and after



 
Click OK.

Next, let's look at making lines. Click the L Button to access the Lines window.

For the BIHL, we are going to be running our games with No Lines Changes, so this screen is important. The line that you will be using is
the top one, appropriately named No Line Changes (NLC). Right now, our boy Jack is in the Forward Extra Attacker position. I want to
move him to Centre, so I double-click the NLC line.
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Click the drop-down boxes and select the correct players for each position.

 
Our players are in the correct positions now, so click OK.

Please tune in next time as we continue our tutorial!
Last edited: Oct 4, 2017
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MODIFYING NHL '94 - Part Five: Using your NOSE and EARE 2

The next thing I want to show you is how to change uniform colours in NOSE.

So, open NOSE and the ROM you are modifying.

If you used the uniform test .psd file back in post number 2 of this thread, open any uniforms you made with it. I'm going to continue with
the Cones, so I'm going to need the uniform I made for them.

https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-60528
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-60528
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-60528


 
In NOSE, click the S Button to make the Strips window appear.

First, click the Sample check box right under the player image.
Then, choose a colour you want to insert into your uniform. 

(For the BIHL, the home uniforms are dark, so there will be a lot to change)



 
Then, choose the place on the uniform you want that colour. (beside the 0002)

 
Continue with the other colours of the uniform.

NOTE: It's generally a bad idea to mess with the colours: Ice, Blade, Boots/Glove, Face, Stick and Shadow. This will change things for all
teams and sometimes mess things up.

So, I've replaced the colours on the visitors uniform to what I want:



 
You'll notice the top set (Sample) has changed, but the bottom (Visitor) has not.

Click Apply

 
now that uniform is set. By using the Sample bar, it is possible to copy and paste uniforms on multiple teams (which is useful for All-Star
teams and... not much else)

Next, let's do the same for the Home uniforms. One useful thing to remember is that if you RIGHT-Click on a square, you copy that
colour. I want the Home and Visitor pants to be the same colour, so I'll right-click on the pants slots on the Visitor set and left-click on the
corresponding slot on the Home set.



 
The right-click to copy feature is useful for re-using colours in different places.

Then click Apply on the Home side to set the colours.

 
click the T-Arrow buttons to move to the previous/next team.



Next, I want to set the menu default options. This are the values that automatically show up when the game starts.

Click Window>Other Windows>Menu>OK to access the Menu window

 
For the BIHL, we want the game to simulate itself, so I'm going to set the Players to Demo. I'm also going to change the starting teams,
and goalies (which won't actually change anything in Demo Mode)

 

That's all we're going to do for now with NOSE, so save your file and close NOSE.

Next let's use EARE to change a few settings.

Open EARE and open your ROM.
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The only thing we are going to do with this today is set the number of teams that show up on the menu screen. In the Selectable Teams
window, I'm going to click the drop-down menus and choose the number of teams in my league (8).

 
Click Save, then close EARE.

That's all for today's installment. I'm actually going to take a bit of a break from this tutorial until the BIHL is finished its draft and I'm
finished all the previous steps for that league.

See you next time!
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MODIFYING NHL '94 - Part Six: Inappropriately Named Software I

Okay, remember a while back we made logos for our ice and team select screen? Today I'm going to show you how to put those in your
game.

First, I want to show what it looks like before you do it. So, I'm going to start up my Genesis emulator and take a few pictures.

https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-62122
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As you can see, they are the NHL logos, and the colours are different. That's because when we changed the uniform colours, we also
changed the palette they were linked to. This will be important for us later.

To input our logos, we will be using the unfortunately-named Tile Molester software, so make sure you have it installed and running. As I
mentioned, this is a Java application, so you may have to take some steps to get it working. I did, but I can't actually remember what I
had to do. Google it. :P

I'm also going to open this page in my internet browser:



Share 

This is the reference for all the important addresses we need. It comes from an NHL 94 wizard who goes by the handle wboy, so the
credit all goes to him.

So, once you have Tile Molester (which I'm going to just call TM from now on) open, click File>Open and find your ROM folder. Make
sure you click the drop-down menu and choose All File Types or you may not see your ROM right away.
Once you open it, it should look something like this:

Next, Click View>Codec>4bpp linear



Now, this is where it gets confusing.

Remember when I said the ice logo palette was linked to the uniforms? Well, we need to know the location of that palette data in the
game, and the place to find that is in NOSE, which we used to change those palette colours.

So, we need to open NOSE.

In NOSE, open your ROM (don't worry, you can have it open in TM and NOSE at the same time. Just DON'T save anything in NOSE,
just in case.

Click the S Button to open the Strips window.

You'll see in the picture below there is a section of the NOSE screen shown:

To get that information, find the Offest Decimal Button, or Click Options>Offset>Decimal, or Ctrl-D (It must be important if it has three



ways to do it!)

Next, in TM, Click Palette>Import From>This file

In the offset box, enter the number you see in NOSE. In my case it is 1952334. In the Size box, input 16. Click the Format drop-down
menu and choose 9bpp BGR (Genesis). In the Byte Order, choose Motorola.

Don't worry, you don't have to enter all the information every time.

At this point, my screen looks like this:

Next, we are going click Image>Canvas Size and enter 6 in the Columns box and 4 in the Rows box.

TM uses tiles instead of pixels, with each column or row having 8 pixels. Bits and bytes, baby. 

Next click View>Zoom and zoom in to see the tiles better.

Then, click Navigate>Go to and enter the location of our logo data, 1d6f02

My screen now looks like this:



You see the logo we saw in the game back at the start of today's lesson.

Now let's import our new ice logo

Click Edit>Paste From and navigate to your logo folder. Open your ice logo and it should appear on your screen like this:

Notice the area around the logo is white and not blue. This is because the logo isn't actually set yet. If you hover your mouse cursor over
it, you'll see you can actually move it. DON'T. 

Click on the gray area surrounding the the picture and the white will turn ice blue. Like this:



Okay, one down, seven to go. 

Let's navigate to our next logo data. Click Navigate>Go to
This time, click the Relative Mode option on the right. This will make us jump to the next logo. That way we don't have to enter each
location separately.
Enter 30a (that's three-zero-A) in the offset box and click OK
Your screen should look like this:

You'll notice that the B logo still has the Cones green and brown colours. We have to also find the correct palette for this logo. So, click
Palette>Import From>This file



Now we have to go back to NOSE and find this team's palette location by clicking the Next Team button or selecting the team from the
drop-down menu.

 
You can see this team's Offset number is 1952794, so enter that in the Offset box in TM
Click OK and you'll be the colours change with the new palette.



 
Next, let's import our next logo by clicking Edit>Paste From and opening our next logo. Don't forget to set the logo in place by clicking the
gray area next to the logo.
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TM automatically chooses what it thinks is the closest colour for the imported graphic. Sometimes this is where you see the limitations of
the small palette.

Next, Click Navigate>Go to Again

The next logo should appear. Again, get the palette location from NOSE.

Again, import with Edit>Paste From

and continue until you have all your logos in the game. Save your work.

Now, let's test our work. Open up your emulator again and boot up the ROM.

Start a game in an arena with one of your new logos.

It should look something like this:

 

And there it is!

One common problem with this is TM not choosing colours well in importing logos, so it's important to use similar colours in your logos.
See the post above on making logos to make this better.

Also, make sure the background on the logo is ice blue. Sometimes TM will choose a different colour. If so, use the flood fill tool or the
brush tool in TM to manually input the ice background.

Last edited: Oct 16, 2017
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The Community



MODIFYING NHL '94 - Part Seven: Inappropriately Named Software II
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Okay, in today's tutorial, we're going to do the select screen logos.

Again, we'll start with TM. The starting points are the same, so if you're continuing on from last time, you can skip ahead a little.

Run TM, open your ROM

Click View>Codec>4bpp linear

The team select logos are 48x48, which is 6 tiles by 6 tiles, so click Image>Canvas Size and enter 6 in both boxes.

Zoom in with View>Zoom for a better view of the logo.

Click Navigate>Go To and enter 1c85b8 into the offset value box and click OK

Your screen should look something like this:

Now, this part is actually a little easier with colours than the ice logos. You have much more control over the palette.

First, let's load the palette by clicking Palette>Import From>This file

Enter 1868270 in the Offset box, 480 in the Size box and make sure the format is Genesis and the byte order is Motorola, like this:

 
It should now look like this:



Now, we're going to open up Photoshop (or whatever you use to edit graphics) and open the logo we're going to import.

Next, use the eyedropper tool to select a colour on your logo. For example, I'm going to select the brown of the cone.
Then, click the Set Foreground Colour box to view the RGB values.



 
As you can see the values are Red-153 Green-0 and Blue-0.
Go back to TM.
At the bottom of the screen you can see the palette. You can change any of the values of the bottom row of colours.
ONLY CHANGE THE BOTTOM ROW
Bad things can happen if you mess with the other colours. You can use them, but don't change them.

 
I'm going to double-click on the bottom left colour.

 
Click the RGB tab



 
Enter your RGB values into the boxes, hit enter, then click OK.
Repeat with the other colours in your logo. When we made the logos before, we used a limited palette, so there shouldn't be more
colours than you need in the palette.
Luckily, our Cones logo only has three colours, brown, green and black.

 
Now we have a strangely-coloured Ducks logo and a new palette.
Now, let's import our Cones logo by clicking Edit>Paste From and opening our logo.



Remember to click on the gray area next the logo to "set" it in place.
If you save it as is, your logo will have a white background on the select screen.
However, I like to have a transparent background on my logos, so I'm going to use the flood fill tool to make the background clear. Click
on the top left colour in the palette and select the flood fill tool. Then click on the part you want to make clear.

 
As you can see, it's now blue.
Now let's go on to our next logo.

Click Navigate>Go To and enter this information:



 

Next, click on the right arrow next to the palette. This will take you to the palette for that logo.

Now do the same thing we did with the first logo: Use Photoshop to find the colour values of your logo and enter them into the bottom
row of the palette.
You'll probably end up with something like this:



 
Then import your logo with Edit>Paste From and click the gray area to set the logo in place.
If it doesn't look how you want it, Undo and adjust your colours more to match your logo.
This Mashers logo actually took four tries before I got this:
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Continue the process until you have all your logos in the game.
Once you're finished, save your work and load you ROM into your Genesis emulator to test it.

Ken Meredith
The Community
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This is fantastic
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Part Eight - Setting your setting

So, a few parts ago, we made location banners for our teams. Let's put those in the game next.

Open up your ROM in TM again, and change the settings as always:
View>Codec>4bpp linear

For this part, this image is going to be our guide:

So, click Image>Canvas Size and enter 11x60 as the dimensions
Navigate>Go To and enter 1d16cc
Palette>Import From>This file and enter 1927500 in the Offset box and 64 in the size box. Don't forget to also change the Format to
Genesis and Byte order to Motorola.

NEW: This part doesn't use the first section of the palette, but the second, so click the right arrow next to the palette once.

Your screen should look like the image above.

It is important here that you DO NOT change any of the palette colours.

Now, let's import our banners.

Click Edit>Paste From and find your banner graphic.
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Again, click the gray area next to the graphic to set it in place.

Next, import the next logo. You'll notice it shows up on top of the first logo.

Don't click on the gray area this time. Move the logo down on top of the second logo like this:



 
Now, click the gray area to set it in place.

Continue with the rest of your banners. If you have a lot of logos, you may have to zoom out in order to be able to move them to the
lower sections.



 
Next, let's change the colours. For this part, I usually like to zoom in a little bit.
Click on a colour close to your team colour and use the flood fill tool to change the colours.



 
This is one place where the limited palette is a problem. As you can see, there's no purple, for example.
Also, I never use the ice blue, white or black in this section. The letters are white and the shadows are black, and the ice is transparent.

The pause menu banners are done.

However, there are still the select menu banners, so let's get those out of the way too while we're here.

We're going to use this image as a guide:



We're also going to need to check the colours on our logos, so we'll need to use Photoshop's colour picker again.

Click Image>Canvas Size and enter 11x2 as the dimensions.
Click Navigate>Go To and enter 1c710c as the location.
Click Palette>Import From>This File and enter the above information (Offset 1862018, Size 960)

My screen looks like this:

Next, we're going to change the palette colours as we did with the select screen logos.
Double-click one of the colours on the palette, click the RGB tab, and enter the values from your logo.



Next is the tricky part. Click the right arrow next to the palette.

Don't worry that there's nothing in the bar. It's actually the VISITORS banner, and it's out of our view at the moment.
Change the visible palette colours to the same values as the last part if you want the same colours for home and away banners. You can
also use different colours if you want different home and away colours. I want the same so I'm going to use the same.

 
Click the right arrow to go on to the next home banner. 
Change these colours as you like as well.
Continue until all your teams are taken care of.
Save your work.
Let's look at things in the game. Start up your emulator and check.
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Looking good 
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New file added

Main Title screen template:
https://drive.google.com/open?id=0B354l2YN_7EnUVVtUFl2WWN1cVE

 
This is a Photoshop template for making the Main title screen in NHL '94. I'll be using it for a future tutorial lesson.
It includes layers to show where the logo elements show up.

Patapluumqvist
M.V.P.



are we able to edit the fans?

Ken Meredith
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Lafleur said: 

Short answer: no.

are we able to edit the fans?

Suolitus
Veteran



Ken Meredith said: 

So is the longer answer yes, but it is nearly impossible

Short answer: no.

Ken Meredith
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Suolitus said: 

You read between the lines well.

So is the longer answer yes, but it is nearly impossible
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Part Nine - Finishing Opening touches

With most of our in-game graphics done, it's time to tie some of the loose ends. Today I'm going to edit the opening screen (or screens)

First, grab the file from post 22 in this thread and open it in Photoshop

 
First, let me explain the parts of this image.
The bottom centre bar is where the game credits appear.
The two top bars are for logos. In the original game, they are the NHL and NHLPA logos. In the ROM I'm currently using, they are
actually empty, so you won't see them. This is the way I want them for this ROM, so I'm not going to touch them. If you do want
something to fly into these spaces, please refer to THIS page for the editing details. You'll use the same process as below, just with
different images.

Next, I'm going to make all the layers invisible, and add this layer I made as a background:

 
Then, I'm going to add the various titles and stuff I want on my screen.
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Notice I left out the letters in my logo. That's because I want them to be part of the moving title. 

 
You'll see I've positioned the logo so the letters fit in the centre bar. The letters SHOULD slide into that space. 
Next, I'm going to reduce the palette size by clicking Image>Mode>Indexed colour
I use these settings, the same I've used on my other graphics:

 
Then, I'm going to save the file as a .png

 
You can see there's some slight changes.

Now, I'm going to copy the letters I want to slide in into a new 240x48 file. Then fill in the background with the game's transparent colour,
a 100% green (0,255,0)
I get this:

 
Next, let's open up TM and open our ROM
Change the initial settings as always, View>Codec>4bpp linear

First I'm going to put in the letters into its place:



Click Image>Canvas size and set it to 30x6
Click Navigate>Go to and enter 11ac22
Click Palette>Import From>This file and enter 1163938 in the Offset box, 64 in the size box, and make sure the format is Genesis and the
byte order is Motorola.

You won't be able to see the graphic yet, just a purple bar. Click the right arrow next to the palette until you see it. My screen looks like
this:

If you need to, you can change some of the colours in this palette. Don't touch the green in the first position, or the purples at the end. I'm
only using black, so I'm not going to change anything.
Click Edit>Paste From and import your file.
Don't forget to click in the gray area to set the picture in place.

Next I want to import the background file I made earlier.
Click Image>Canvas Size and enter 32x28
Click Navigate>Go To and enter 1125a6
Click Palette>Import From>This file and enter 1152422 in the offset box



I'm going to adjust some of the colours in the palette to match my image. 
Double click on a colour in the palette to open the Edit Colour window. 
Use the Colour picker in Photoshop to select a colour in your image.
Enter that colour's values in the RGB tab and click OK.
Once you think you have a matching palette, import your image with Edit>Paste From
This is what mine looks like now:

I'm pretty happy with that, so I'm going to save it and see what it looks like in the game.



 
Wow!
As you can see, the letters aren't lined up correctly. 
I'm going to go back into Photoshop and try to fix it by moving it about five pixels to the right.

After adjusting my letter image file and re-importing it into TM, I finally got this:

 
The letters fly in and land in just the right place.
Mission Accomplished!

Next, let's try the other opening screens.

The first splash screen (the first screen to appear when you start the game) requires these settings:
Canvas Size: 40x28
Navigate: ffaea
Palette: 1083114



Now to be honest, I don't have a file ready for this screen, but I want to use the BIHL logo, so I'm going to quickly make that by copying
the file from TM.
Click Edit>Copy To
Give the file a name and save it somewhere on your computer.
open that file in Photoshop.

I'm going to erase this background and insert a BIHL blue background. Then, I'm going to copy my BIHL logo.

 



Remember, if you have a picture with many colours, you have to reduce the palette. This picture only has four colours, so I won't bother.
Import the file back into TM, adjusting the palette colours as needed.

The second splash screen is a little trickier, but not too unmanageable.

Its settings are:
Canvas Size: 40x28
Navigation location: 109058
Palette: 1003874

Now for some reason, this image has three associated palettes, 1, 3 and 4.

Luckily, I want to use a pretty easy image: the BESL logo on a black background. Like the last screen, I'm going to click Edit>Copy To
and open the file in Photoshop.

Again, I'm going erase everything and put in a black background and paste in my BESL logo.

 
The BESL logo has blending, so I had to reduce the palette.
Next, I'm going to adjust my palette in TM. The important thing to remember is that there are three, and you have to do them all.

The last thing I'm going to do today is the in-game timer logo.
Canvas Size: 7x2
Navigation location: 11de7c
Palette: 366884 (size 64)
This graphic uses palette 2, so click the right arrow next to the palette once.
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As above, I wasn't expecting to have gotten this far today, so I don't have a graphic prepared. So, again, we're going to export using
Edit>Copy To
I'm going to open this in Photoshop and play around with it.

 
Then Import back into TM and save.
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Okay, here it is, the very first BIHL Season One ROM

Fire up your Sega Genesis Emulators!

https://drive.google.com/file/d/0B354l2YN_7EnTHB5XzVBcE05bWc/view?
usp=sharing

Download this file and marvel at the wonder that is the Blue Ice Hockey
League!

Ken Meredith
The Community



I've started converting the team uniforms over to the official BESL template:
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Spoiler: Thetford

Spoiler: Windsor

Last edited: Dec 18, 2017
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Ken Meredith said: 

cant wait to see the armada done up

I've started converting the team uniforms over to the official BESL template:

Spoiler: Thetford

Spoiler: Windsor
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Spoiler: Maritime
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The latest ROM - used for GD3
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Part Ten - Finer touches

It's been a while since I've done any modding to the NHL 94 ROM, but I recently did work on the latest BESL 94 ROM, and wanted to try

something new: changing the in-game font.

Since the work is time-intensive, and finished, I'm going to show you the before and after shots along with the instructions.

We're going to be using Tile Molester again, so open it up, and open your ROM.

As always, click View>Codec>4pbb linear

Then click Image>Canvas Size and change both values to 1
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Next, click Navigate>Go To and enter AAC7C in the offset box, then click OK
My screen looks like this:

 

We're not going to change the palette, mostly because I don't know the location! Just remember that the fist colour is transparent, the
second is white and the third is black for this font.

Click the >> (page forward) and << (page back) buttons to navigate between the letters and symbols in the font.

Use the tools on the left like any other graphics program to change the letters to the shape you want. As I said before, it's easy, but takes
time. As far as I know, the best way to do it is by hand. It is possible to import images like other parts previously covered, but I don't
recommend it.

Here's my before and after:



NOTE: The zero also pulls double-duty as the capital O.
Also, you have to do the upper-case and lower-case letters. Like I said, easy but takes time.

Here's what it looks like in-game:

 



 

 

Next, we have to do the main menu text, which is a little different. The main menu text appears on top of a mesh-like graphic, which is
actually part of the font! That makes it harder!

First, click Window>New Window so you have two windows open. For one window, click the forward and back buttons to go to the first
letter you want to change.
Click in the OTHER window, and Navigate to BE294
Again, click over to the matching letter.
Here's an example of what it looks like:



 
Then, choose the Selection tool from the toolbar on the left.
Drag over the source (the left in the image above) and press Control-C to copy.
Click in the destination window and press Control-V to paste. Don't forget to click in the grey area around the image to set the image in
place.
You also have to click in the source window's grey area to reset that image too.

You'll notice in the image above two things: one, there are annoying yellow dots everywhere and two, one of the colours is different.

Let's deal with them in order. The yellow dots are the mesh needed for the main menu screen. Luckily they are in the same grid pattern
in all the squares. Make the top-right square yellow and alternate from there.

Next, click the purple square in the top row of the palette to choose that colour. Then click the Colour Replacer tool from the toolbar and
click the light beige colour to switch colours.

It should look like this:



 

Continue for the rest of the letters and numbers.

Here's what it looks like in-game:
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It takes time, but you only have to do it once... 
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PART ELEVEN - more finer touches

Today's tutorial is an easy one, and uses EARE (and NOSE if you want).

We're going to change the profile pictures of our players!

There is a way to put in your own original profile pictures, but I'll show you how to do that some other time. 

Right now I'm working on the BIHL Season 2 ROM, and to keep the retro feel I want to use the pictures already in the game.

So, let's get started!

First, Download this file
https://drive.google.com/open?id=1mK_DCXg1yKfFyUh3W62Aihk7uWkVdfmC
This is an html file (for your web browser) with a list of all the photos in the game and their names.
It looks something like this:

https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/members/ken-meredith.34/
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-98356
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-98356
https://pucktheory.com/community/threads/bihl-graphics-mods-and-roms.1382/post-98356
https://drive.google.com/open?id=1mK_DCXg1yKfFyUh3W62Aihk7uWkVdfmC


 
Next, open your EARE folder and look for a text file called PlayerCardsDefault

Make a backup of this file!

If you ever want to change anything back, you'll need it.

Next, open the original text file (not the backup, of course). It should look like this:

and so on...

Next, open NOSE and the ROM you're editing.

Choose a player from your roster, and (from the .html file) which picture you want to use.

As an example, I'm going to change the pictures for the Thetford Miners.

In NOSE, I'm going to select the Goalies tab and open the attributes for superstar goalie Julien Baril.

Template Picture,000C63F8
Player Left,000C682E
Player Right,000C6B98
Goalie Right,000C6F02
Goalie Left,000C726C
Andy Moog,000C75D6
Ray Bourque,000C7940
Adam Oates,000C7CAA
Don Sweeney,000C8014



 

Select the player name and hit Ctrl-C to copy.

We're going to use Felix Potvin's picture for Julien, because he said so. 

So, I'm going to go back to the text file, hit Ctrl-F and find Potvin's name.

Then, I highlight Potvin's FULL NAME, and hit Ctrl-V to paste Julien's name over Potvin's name.

So that line, before:
Felix Potvin,000E12F2

and after:
Julien Baril,000E12F2

Next, I'm going to change the picture for Andrew Walker to Dino Ciccarelli's

In NOSE, I click on the Player Tab and open Walker's attributes.

I copy his name.

Go to the text file, and Ctrl-F Dino's name

Before:
Dino Ciccarelli,000CD8D8

After:
Andrew Walker,000CD8D8

In case you were wondering, the code after the name is the location in the ROM of the picture data.

After I've changed whatever names I want, I'm going to save the text file.

Then, open EARE and open your ROM.



You can see a small window in the bottom right labeled Set Player Pictures.

Make it bigger.

 

Click the button marked Set Player Pictures.

Click OK

Save your file.

Now when you start your game, Julien has Potvin's photo:



Share:       

  BIHL - The Blue Ice Hockey League

You must log in or register to reply here.

 

And Andrew has Dino's pic:

 

SUCCESS!

https://pucktheory.com/community/login/
https://pucktheory.com/community/forums/bihl-the-blue-ice-hockey-league.36/
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