RetroArch Tips and Troubleshooting


Recommended Posts

"Tips and Troubleshooting" Cheat Sheet

These are some issues and some fixes for RetroArch.  The fixes and more details are in the messages below.

TROUBLESHOOTING

  1. No Audio Issue 
  2. Win10 Jumpy Video  see Issue 8
  3. SNES "Multitap" Netplay Issue
  4. Mac Fullscreen/Hotkey Issues   fixed in 1.7.9+ 
  5. "Slow Motion" Video
  6. "Black Flicker" Issue  fixed in 1.7.9+
  7. No longer a problem with 1.7.9+
  8. Audio/Video Stuttering and Poor Framerates

 Please share your short tips and tweaks in the thread below!   We want to cover as many situations as possible, and build this Cheat Sheet.


TIPS

A. Use Direct Connection (instead of Relay) if Possible
B. Hot Swapping Home and Away with "i" Keyboard Shortcut
C. Hotkeys (Keyboard Shortcuts)

 

  • Thanks 1
Link to post
Share on other sites

Issue 1: No Audio while ROM is playing

BETTER FIX:

dsound audio driver stinks. Please use the xaudio driver:

MAIN MENU -> SETTINGS -> DRIVER

Change the "Audio Driver" to "xaudio" (if you haven't touched it, this is the default setting).

Start a ROM, if you have no sound, exit RA and install the following Microsoft package - 

Microsoft DirectX Runtime Package - NOTE in the 1.8.5 package, this is included. Go into the RetroArch-1.8.5 folder and look for the DirectX Installer folder. Run the application in there (need internet access)

Once installed, start RA and load a ROM. Audio problem should be fixed.

 

IF THE ABOVE STILL DOESN'T FIX THE PROBLEM:
If you are playing a ROM and can't hear anything, try this:

MAIN MENU >  SETTINGS > DRIVER

Change the "Audio Driver" to "dsound", restart RetroArch, and try it again. This fixes the issue.

 

  • Like 1
Link to post
Share on other sites

Issue 2: Jumpy Video in Win10

To check your monitor refresh rate - https://www.windowscentral.com/how-change-monitor-refresh-rate-windows-10. Set this to 60Hz.

Jumpy Video and Stuttering Audio go hand in hand. It is usually due to the estimated refresh rate being too low, compared to what the monitor is set to run at. Please see Issue 8 below.

Link to post
Share on other sites

Issue 3: SNES "Multitap" Message During Netplay

In Netplay, after connecting, you get an in-game screen message "Multitap 5 needs to be connected to Player # 2" - For some reason, RetroArch thinks there's a multi-tap connected to Player 1.

To fix go to:
QUICK MENU > CONTROLS
and change the Player 1 to "SNES Joypad".

One or both players may need to do this. Return to the game and it should work fine.

Edited by aqualizard
Link to post
Share on other sites

Issue 4: On Mac in Fullscreen Mode, Hot Keys Not Responsive

Fix: Fixed in RetroArch version 1.7.8+


On Windows, you can use the "F" hotkey to toggle in and out of fullscreen.  Does not appear to work for everyone on a Mac.

However, to scale your window you can use:
MAIN MENU > SETTINGS > VIDEO
and use the "Windowed Scale" settings to change the size of the screen.

Link to post
Share on other sites
On 12/5/2018 at 5:14 PM, aqualizard said:

Issue 5: Slo-Mo Video 

(from Buc on Discord)

MAIN MENU > SETTINGS > DRIVER
and turn on "Threaded Video".

With Threaded Video set to Off,  Buc said "it looked like it was going into slow motion half the game even when I was just playing the computer."

Buc uses Win10.
 

I would recommend not using "Threaded Video". This should be a last resort. Win 10 has messed up OpenGL drivers for some video cards, so if you have a problem, change your Video Driver to "d3d11" in Settings-Driver. This may fix it. Also, follow the instructions here:

Perfect Audio/Video Sync

Link to post
Share on other sites

Issue 6: Black Flicker

Fix: Fixed since RetroArch version 1.7.8+. No longer an issue

Description: A black flicker -- where for a brief moment the entire RA screen is black -- happens at regular intervals.  Intervals can be only a couple seconds apart (making game unplayable) or every minute or so.  We think it has to do with the refresh rate getting out of sync.  We also think it happens more for the person connecting than the one hosting, or possibly only on the connecting side.

More to come as we investigate....

In the mean time, possible play with the VSync, Refresh Rate, etc. under MAIN MENU > SETTINGS > VIDEO
Also, it may help for the user experiencing the flicker to host. (Which requires that they use "Direct" connection, and "i" hotkey to be visitor.)

Link to post
Share on other sites

Tip A: Use Direct Connection (instead of Relay) if Possible

Direct is better than Relay.  Ideally at least one player has a Direct Connection.  They should be host, and you can use the "i" shortcut (see below) to swap home and away as needed.

There is a writeup for creating a Direct Connection here: RetroArch Setup Guide (it is at start, in sections 1 & 2)

 

 

Edited by aqualizard
Link to post
Share on other sites

Tip B: Hot Swapping Home and Away with "i" Keyboard Shortcut

One great thing about RetroArch is you can "hot swap" home and away.  As long as the guy hosting is using Direct Connection.  You can even do it mid-game or whenevs.  This is super handy.

To start, let's say both guys are connected.  The host  will be home, since he connected first.  If you need to change that, do this:

1. the host hits "i" to leave (right from ROM menu or wherever, it will not reset anything)
2. the other guys hits "i" to leave, then "i" again to reconnect (he will be home now, because he is "first" to connect)
3. the original host now hits "i" to re-connect, but because he is 2nd to connect now, he will be visitor

Tada!!

Ideally, at least one guy will have Direct Connection ability.  That person should host. (If both are Direct capable, it doesn't matter who hosts.)

Edited by aqualizard
  • Like 1
Link to post
Share on other sites

Tip C: Hotkeys (Keyboard Shortcuts)
 

f	- fullscreen
i	- "leave the game" - Used when switching player positions or when spectating. "Leaving the game" is similar to unplugging your controller from the console.
F1  - Quick Menu when in game
F5	- save state
F6	- decrease save state slot
F7	- increase save state slot
F4	- load save state
ESC	- hard exit

NOTE: Config is set up to auto-increment save states. You do not need to change save state slots after hitting F5.

 

 

More to come...

Link to post
Share on other sites

Issue 8: Audio Stuttering and Slow Framerates (PC only)

 

This is probably one of the most common issues I hear about - "My audio is stuttering!!!"

 

The problem - Audio stutters because of the video frame rate is incorrect. All retro consoles and console cores on RetroArch strive for a ~60fps frame rate (retro consoles and games are designed to run on 60Hz, which is 60 frames/sec (or close to it - this is NTSC spec, 16.7ms/frame * 60 frames = ~ 1 second). Your PC/laptop monitor usually runs on 60Hz refresh rate, so the video should be flawless with no slowdown. Simple, this should work perfectly, right? Sometimes yes, sometimes no.....

Even though your monitor's refresh rate is set to 60Hz, Windows has overall control on what to allow programs to run at (via your graphics card's video driver). So, even with a 60Hz refresh rate monitor, and a program that displays video at 60Hz rate, Windows can tell your program to go F itself and only allow it to run at 30Hz (example). This problem is a major one in Windows 8-10, and usually happens with programs that are running in a windowed mode.

Why is the audio stuttering?

Well, monitor refresh rates aren't ALWAYS a perfect 60Hz. Depending on many factors (heat is one), the refresh rate fluctuates, very slightly (for example, it might bounce around between 58-61 Hz). This isn't a major problem, because these small changes are not noticeable by eye to us. 

Fortunately, RetroArch monitors this. In order to sync up the audio to the video properly, it "adjusts" the audio to the refresh rate. So, if one minute, the refresh rate is 58Hz, it will slow down the audio to match it up with the slower video rate. If another minute, it's at 61 Hz, it will speed up the audio to sync it with the video. 

The audio stuttering occurs when your refresh rate is something absurdly different (like 50Hz, or 30Hz). Well, now, the audio will sound like absolute crap, even though to you, the video might still be running at an OK speed.

So, the problem isn't the audio, it's the video. 

 

The solution - First, we need to check what the actual frame rate is of your monitor. This can be checked in RetroArch, under Settings-Video. You will see 3 important values: Vertical Refresh Rate, Estimated Screen Framerate, and Set Display-Reported Refresh Rate.

Vertical Refresh Rate - This is the rate that RetroArch uses to sync the audio and video. This is 60Hz by default.

Estimated Screen Framerate - This is the actual current frame rate of the monitor. This will fluctuate and that is normal (see description above). Though, the fluctuation should be small. This value should be very close to the "Vertical Refresh Rate". If not, you will see slowdown in video and screwy audio. This shows a deviation from the "Vertical Refresh Rate" in a percentage, and also shows a frame count.

Set Display-Reported Refresh Rate - This is the refresh rate the your monitor is set to. If you change your monitor's refresh rate in Windows, it will be displayed here. This should be 60Hz (except in very special cases, like high-end gaming monitors). If it isn't set to 60Hz, change it (in Windows) following this guide - How to change monitor's refresh rate. After you change it, you will need to exit and restart RetroArch.

Good Refresh.png

 

The important one to look at is "Estimated Screen Framerate". What value is this? Is it close to 60Hz? If so, you can leave it alone, your audio is most likely fine, and you don't have this problem, or something else is causing it.

Many people running older laptops with Windows 8 or 10 will see "Estimated Screen Framerate" in a range of 30Hz-60Hz. This is Windows controlling the frame rate via your video card. Many times, the easiest solution is to play in fullscreen mode (hit the "f" key to toggle fullscreen mode). You should see your "Estimated Screen Framerate" jump up to ~60Hz.

 

So, what's the solution? Play in fullscreen mode. If this still doesn't fix the problem, I suggest trying a different video driver (under Settings-Driver). The default is D3D11 (Direct3D 11), but try using the "gl" driver. After changing the driver, you will need to close and restart RetroArch to see an effect. Then, try again, under Settings-Video, looking at "Estimated Screen Framerate", toggling between windowed mode and fullscreen. 

 

  • Like 1
  • Thanks 2
Link to post
Share on other sites
  • 3 months later...
On 12/4/2018 at 10:18 PM, aqualizard said:

Issue 2: Jumpy Video in Win10

(from Chaos and Viz on Discord)

MAIN MENU > SETTINGS > DRIVER
Change the "Video Driver" from "gl" to "d3d11".

Also go to:
MAIN MENU > SETTINGS > VIDEO
and turn on "Hard GPU Sync".
 
This should get rid of the choppiness. Windows 10 screwed up their GL video driver with a recent update
Most noticable thing is when you go into MAIN MENU > SETTINGS > VIDEO, look at your "Estimated Screen Framerate". It should closely match the refresh rate of your monitor (most likely ~60Hz, unless you have a fancy monitor).
To check your monitor refresh rate (don't change it) - https://www.windowscentral.com/how-change-monitor-refresh-rate-windows-10

@chaos asked me to post this verified fix here, however follow the warnings in the attached steps:

  1. Press Windows Key + R to open the Run Dialog Box.
  2. In the Run Dialog Box, type regedit and click OK to open the Registry Editor.
  3. In the navigation pane on the left, double click the folders to navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender.
  4. If you find a registry entry named DisableAntiSpyware, double click it and set its value data to 1.

4b. If you do not see a registry entry named DisableAntiSpyware, right click in the main Registry Editor pane and select New > DWORD (32 bit) Value.

4c. Name this new registry entry DisableAntiSpyware. Double click it and set its value data to 1.

*** Keep in mind that doing so leaves you vulnerable to a range of cyberattacks, so it’s critical that you install an effective anti-malware product on your computer before removing Windows Defender. ***

I have done this twice successfully for myself on two different computers, and twice with two others that aren't me. To find out if this fix is likely to work for you, hit CTRL-ALT-DEL and load up your task manager. Sort by CPU usage. If antimalware service executable is your top CPU hog, and you have framerate issues, killing it and restarting your comp will be likely to fix this. Cheers! And please let me know if this fix worked for you too.

  • Thanks 1
Link to post
Share on other sites

It might be possible to disable WIndows Defender from scanning RA, rather than disabling it completely?

https://winaero.com/blog/exclusions-windows-defender-windows-10/

You'd select "Process" in step 5 and then find the retroarch executable. Do this step while RA is running.

Link to post
Share on other sites
On 10/28/2019 at 4:37 PM, chaos said:

Issue 8: Audio Stuttering and Slow Framerates (PC only)

 

This is probably one of the most common issues I hear about - "My audio is stuttering!!!"

 

The problem - Audio stutters because of the video frame rate is incorrect. All retro consoles and console cores on RetroArch strive for a ~60fps frame rate (retro consoles and games are designed to run on 60Hz, which is 60 frames/sec (or close to it - this is NTSC spec, 16.7ms/frame * 60 frames = ~ 1 second). Your PC/laptop monitor usually runs on 60Hz refresh rate, so the video should be flawless with no slowdown. Simple, this should work perfectly, right? Sometimes yes, sometimes no.....

Even though your monitor's refresh rate is set to 60Hz, Windows has overall control on what to allow programs to run at (via your graphics card's video driver). So, even with a 60Hz refresh rate monitor, and a program that displays video at 60Hz rate, Windows can tell your program to go F itself and only allow it to run at 30Hz (example). This problem is a major one in Windows 8-10, and usually happens with programs that are running in a windowed mode.

Why is the audio stuttering?

Well, monitor refresh rates aren't ALWAYS a perfect 60Hz. Depending on many factors (heat is one), the refresh rate fluctuates, very slightly (for example, it might bounce around between 58-61 Hz). This isn't a major problem, because these small changes are not noticeable by eye to us. 

Fortunately, RetroArch monitors this. In order to sync up the audio to the video properly, it "adjusts" the audio to the refresh rate. So, if one minute, the refresh rate is 58Hz, it will slow down the audio to match it up with the slower video rate. If another minute, it's at 61 Hz, it will speed up the audio to sync it with the video. 

The audio stuttering occurs when your refresh rate is something absurdly different (like 50Hz, or 30Hz). Well, now, the audio will sound like absolute crap, even though to you, the video might still be running at an OK speed.

So, the problem isn't the audio, it's the video. 

 

The solution - First, we need to check what the actual frame rate is of your monitor. This can be checked in RetroArch, under Settings-Video. You will see 3 important values: Vertical Refresh Rate, Estimated Screen Framerate, and Set Display-Reported Refresh Rate.

Vertical Refresh Rate - This is the rate that RetroArch uses to sync the audio and video. This is 60Hz by default.

Estimated Screen Framerate - This is the actual current frame rate of the monitor. This will fluctuate and that is normal (see description above). Though, the fluctuation should be small. This value should be very close to the "Vertical Refresh Rate". If not, you will see slowdown in video and screwy audio. This shows a deviation from the "Vertical Refresh Rate" in a percentage, and also shows a frame count.

Set Display-Reported Refresh Rate - This is the refresh rate the your monitor is set to. If you change your monitor's refresh rate in Windows, it will be displayed here. This should be 60Hz (except in very special cases, like high-end gaming monitors). If it isn't set to 60Hz, change it (in Windows) following this guide - How to change monitor's refresh rate. After you change it, you will need to exit and restart RetroArch.

Good Refresh.png

 

The important one to look at is "Estimated Screen Framerate". What value is this? Is it close to 60Hz? If so, you can leave it alone, your audio is most likely fine, and you don't have this problem, or something else is causing it.

Many people running older laptops with Windows 8 or 10 will see "Estimated Screen Framerate" in a range of 30Hz-60Hz. This is Windows controlling the frame rate via your video card. Many times, the easiest solution is to play in fullscreen mode (hit the "f" key to toggle fullscreen mode). You should see your "Estimated Screen Framerate" jump up to ~60Hz.

 

So, what's the solution? Play in fullscreen mode. If this still doesn't fix the problem, I suggest trying a different video driver (under Settings-Driver). The default is D3D11 (Direct3D 11), but try using the "gl" driver. After changing the driver, you will need to close and restart RetroArch to see an effect. Then, try again, under Settings-Video, looking at "Estimated Screen Framerate", toggling between windowed mode and fullscreen. Also, make sure you are using the "XAudio" audio driver (Settings-Driver). If you switch to it, and have no sound, look at Issue 1 above for a fix.

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.