Jump to content
NHL'94 Forums

Can't save .bin file after saving bmp or png file for Splash screens


Recommended Posts

Yours Truly is trying hard to change the graphics in the roms I do.  I learned a lot in looking for palettes, offsets, setting height and width...still I encounter the following issue.  The .bin file won't save.  At the moment, I only try to change the splash screens, import the images by bmp or png at the right height and width i.e. 320 by 224 ...then when it comes to save I don't know whether to 'Save as' or 'Save all' .  I tried both and when it comes to try the rom, the save did not happen.  I looked around in the forum and either I am a real noob or I am just too old for that, I somehow can't find a solution.  Knowing how to save the .bin appropriately would be a real game changer in my rom hacking experience just like it did when I discover how to use NOSE.  Imagine, I got the puck is getting close to put graphics in his darn roms.  Thank you in advance for any help, hints or links to a post or page you can provide.

Link to comment
Share on other sites

Are you trying to add the image in Tile Molestar? Best route Ive found is shown below. Make sure you have the file you want to import. And once you find it go to EDIT and Paste From... this will allow you to drop the image into the rom. 

NHL95 sometimes its the 8x8 byte in the top corner that needs to be shifted over 1 space to all it to stick.

Also, when it comes to Save As....click Save As, and set it to the name you want with a different version and make sure you put the .bin at the end. I noticed it sometimes doesnt allow me to open the rom.

 

Not sure if this helps.

image.png

Link to comment
Share on other sites

Hey UltraMagnus, as far as putting the image file, I did exactly what you said.  I seem to have no problem importing it.  I wonder if it a problem in using the right palette.  However, I will try to type.bin at the end and see if it makes a difference.  I am so close of doing graphics in roms darn.  I also follow your step-by-step guide and used the same palette number for the opening splash screen.  I am showing here a .bmp copy of the image I want to put.  I will keep you posted if any progress are made.

second screen.bmp

Link to comment
Share on other sites

It might be this?

Make sure you hit Esc (or Enter or.. it's some key but I forget) after importing your image. Then you'll see the colours change to match the palette. If you don't do this it hasn't actually applied the image to the ROM.

Link to comment
Share on other sites

If your importing the image into the rom. Ive noticed, best rule of thumb is to change the palette color first before importing the color. It just seems to work cleanly for me. Using @smozoma ditherer program gives you those 16 bytes of color for the palette. 

Below is the 1st Screen Splash image once its set to the palette (1928696, 64 size, motorola and 9bgpp) and size required (320x224). You can see the palette below in the yellow circle.

image.png

Once you've done that, run the image through smozoma's Ditherer - Choose "1", than find the image you want to use, go through DItherer again and select "3". Which will give you a notepad with the color palette and new image. Ive included them below. 

Change the palette colors from top row left to right with the numbering 1-16 like the notepad shows.

image.png

Once you've changed all the colors, your palette will look like this and image will be screwy.

image.png

Now, go into EDIT --> Paste From... find the image for the one below. and select it. Place it were it needs to be and click away. You will see the colors stick.

image.png

Once, you edit or clean it up you will be able to go to FILE - SAVE AS ---change the name to v1.1 or v1.2 (easier to track, or go back if there is an issue.)

Here it is loaded in my emulator

image.png

Hope this helps.

 

  • Thanks 2
Link to comment
Share on other sites

try to use ditherer, use the right dimensions and save in 24 bit the bmp image...result? image=0, File is too small to be a BMP ????? I am stuck there...will look around for answers...still puzzled and annoyed that I can't get this thing going

Link to comment
Share on other sites

ok...major breakthrough...I succeeded to implant a splash screen...funny and strange thing is I did not do anything to the palette, just put the initial palette number...did not change a thing...only thing I did is to click on the canvas AFTER I paste my image.  Try it again in another file afterwards and it did not work.  here is the file that worked.  will work it more.  stay tuned

Ladies on the pond33.bin

Link to comment
Share on other sites

Thanks, this is like conquering the moon...Love it!!! Now I was able to do both splash screens...have to adjust the image because I want an empty spot to click on to fix the image on the canvas unless there is another command to do that...I used 320 by 224 for the image but reduce it to 304 and then I center it within the tile molester.  Funny thing is that once you modify a .bin file with tile molester, it is impossible for me yet to go back....I get an error message and can't access anymore to mod the .bin file.  Is it normal or am I missing something.  I did a lot tonight of groundbreaking...off to play and watch hockey....Thanks UltraMagnus!!!

Link to comment
Share on other sites

Great to hear your progress. Keep your image the 320x224. Just click away in the grey part of the screen or select another tool. It will stick. 

Important thing is to save your file before making changes and whatever changes you did, save it as a new version. 

Like nhl95-testv1

Then save it to nhl95-testv1.1

 

With the error. Going into the folder where you have the tile molester folder and go under resources folder and enter there. Just delete those files as they are redudent files. It is a little step. But you will be able to open the file again. 

Link to comment
Share on other sites

4 hours ago, I got the puck said:

try to use ditherer, use the right dimensions and save in 24 bit the bmp image...result? image=0, File is too small to be a BMP ????? I am stuck there...will look around for answers...still puzzled and annoyed that I can't get this thing going

Put the program in a path without spaces. That fixed it for someone else, so I guess I have a bug in there...

Link to comment
Share on other sites

ok...things are kinda cool but still need to master these palettes and so on...My bug lately is the second splash screen...the bottom and top of the image has the color screwed...any idea anyone what is going on? The canvas size is 40X28 and with the right palette 1003874...will look around to improve how to use the palettes which is a challenge for me I think...but i'll find out.Ladies on the pond33.bin

Edited by I got the puck
Link to comment
Share on other sites

hey there, I was able to change both splash screen although the second one still have an annoying top violet strip and another black strip at the bottom.  Anyway, I updated the splash screens of two of the team roms I did and the results is quite cool anyway.  I find it easier to copy a logo rather than a full picture.  I still haven't figure it out how to put the right palette to a multiple colored bmp file.  Anyway, here is my two updated roms.

Penguins on the pond v3.bin Islanders OTP2.bin

Link to comment
Share on other sites

On 2/5/2021 at 1:33 PM, UltraMagnus said:

best rule of thumb is to change the palette color first before importing the color.

 

 Yes, you MUST change the palette colours first to get the best results.

Otherwise it just picks the closest colour from the existing palette, so some different colours from your image may get mapped to the same colour index, and if that happens you will lose detail in your image. For example if your image has 2 shades of red, and the existing palette has 1 shade of red, then your final image will only have 1 shade of red, even if you add the 2nd shade of red into the palette afterwards.

Link to comment
Share on other sites

On 2/6/2021 at 11:42 PM, I got the puck said:

hey there, I was able to change both splash screen although the second one still have an annoying top violet strip and another black strip at the bottom.  Anyway, I updated the splash screens of two of the team roms I did and the results is quite cool anyway.  I find it easier to copy a logo rather than a full picture.  I still haven't figure it out how to put the right palette to a multiple colored bmp file.  Anyway, here is my two updated roms.

Penguins on the pond v3.bin 2 MB · 0 downloads Islanders OTP2.bin 2 MB · 0 downloads

I think one of the splash screens actually composed of 2 or 3 images (big central area, plus a bar at the bottom and maybe the top), each with its own palette. So you need to find those other palettes. Pay careful attention in the guide that you probably started with. It should show you all the separate images and palettes.

Link to comment
Share on other sites

ok thanks...will come back here as I have other issues elsewhere for now...worked out a few things and it was better...did great results that I will post up later...had problem still with 2nd splash screen but will investigate later....but so far so good...thanks a lot for your feedback and i'll be back soon.

Edited by I got the puck
Link to comment
Share on other sites

Breaking in a new laptop so I don't have Tile Molester currently downloaded but for that screen if you're using a full screen image you need 3 of the 4 palettes to match what you have for the primary image.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...